Investigating Isolated Call Routing Issues

Incident Report for CallRail

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 13:41 EDT

Monitoring

A fix has been implemented and we're observing normal call routing performance.
Posted Mar 31, 2025 - 13:39 EDT

Identified

We have identified an issue with an upstream vendor that is impacting call routing for some customers. We are actively working with them to mitigate the situation. We sincerely apologize for any disruption this may cause.
Posted Mar 31, 2025 - 12:27 EDT

Investigating

We're currently investigating call routing failures affecting a small portion of calls. Our team is actively working to identify the root cause and restore full functionality. We will provide updates as we learn more.
Posted Mar 31, 2025 - 11:45 EDT
This incident affected: Call Tracking (Call Routing).