Application Dashboard Unavailable
Incident Report for CallRail
Resolved
The problems have been resolved. We recommend users refresh their browsers.
Posted Nov 04, 2021 - 15:13 EDT
Investigating
Some users are experiencing an application interruption. Calls continue to route normally. We are actively investigating this issue.
Posted Nov 04, 2021 - 14:41 EDT
This incident affected: Call Tracking (CallRail Web Application).