Possible Conversion Reporting Issue in Google Ads
Incident Report for CallRail
Resolved
This incident has been resolved.
Posted Jun 22, 2022 - 09:14 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 21, 2022 - 16:21 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 21, 2022 - 13:41 EDT
Investigating
We are investigating reports from some customers that conversions are not being posted in Google Ads.
Posted Jun 21, 2022 - 11:17 EDT
This incident affected: Integrations (Google Ads).