Lead Center Outage
Incident Report for CallRail
Resolved
This incident has been resolved.
Posted Jul 12, 2021 - 12:55 EDT
Monitoring
Inbound and outbound Lead Center calls are functioning again. We're actively monitoring the situation for further disruptions.
Posted Jul 12, 2021 - 12:18 EDT
Update
We are continuing to investigate this issue.
Posted Jul 12, 2021 - 11:16 EDT
Investigating
Starting at 10:30am Eastern, some parts of the Lead Center web application became unavailable due to some technical issues. We are actively investigating the issue.
Posted Jul 12, 2021 - 11:15 EDT
This incident affected: Lead Center.