Degraded Performance in Report Export Pipeline

Incident Report for CallRail

Resolved

This incident has been resolved and the report backlog is now empty.
Posted Mar 02, 2026 - 08:47 EST

Monitoring

A fix has been implemented. Our monitors are showing latency is drastically reduced and jobs are now working through the queue at a normal rate. We have added additional server capacity to work through these delayed jobs as quickly as possible.
Posted Mar 01, 2026 - 21:32 EST

Identified

We are currently experiencing delays in report exports due to degraded performance in our export pipeline. Our engineering team has identified the root cause and is implementing a fix. No reports have been lost. We will continue to provide updates and appreciate your patience.
Posted Mar 01, 2026 - 19:55 EST
This incident affected: Reports.