Latency in transcript delivery

Incident Report for CallRail

Resolved

We are no longer seeing transcript latency. This issue has been resolved.
Posted Jan 29, 2026 - 15:28 EST

Identified

Transcript delivery latency is recovering. We are continuing to monitor performance and provide updates until fully resolved.
Posted Jan 29, 2026 - 14:18 EST

Investigating

We are investigating increased latency in transcript delivery due to an issue with an upstream provider.
Posted Jan 29, 2026 - 13:44 EST
This incident affected: Call Tracking (CallRail Web Application) and Call Transcription.