Ongoing report exporting delays

Incident Report for CallRail

Resolved

This incident has been resolved.
Posted May 01, 2025 - 14:39 EDT

Monitoring

Our engineering team identified the cause of the slow report exports and have added additional capacity to mitigate the export issues. We are monitoring the system and will continue to make updates as they become available.
Posted May 01, 2025 - 11:59 EDT

Investigating

We are investigating delays with report exports completing. The reports are loading and are viewable in the application.
Posted May 01, 2025 - 10:06 EDT
This incident affected: Reports.