Issue Rendering the Call or Form Log on the CallRail iOS Mobile Application

Incident Report for CallRail

Resolved

This incident has been resolved. To implement the fix, please update your CallRail Mobile application to version 6.12.1 or later.
Posted Aug 28, 2026 - 15:59 EDT

Identified

We are aware of an issue on the CallRail iOS Mobile application where the Call and Form Logs fail to render.

We have identified the issue and our team is working on a fix to resolve.

The issue occurs when the application returns more than 1 page of data to be displayed. Customers can work around this issue by using the date filters to narrow the date range so that a smaller set of results is returned.
Posted Aug 28, 2026 - 10:49 EDT
This incident affected: Mobile App (iOS).