Issue with starting trials

Incident Report for CallRail

Resolved

The issue from this morning has been resolved. Thank you for your patience.
Posted Sep 26, 2023 - 13:19 EDT

Monitoring

A fix has been implemented for the earlier Trial Signup issue and we are now monitoring.
Posted Sep 26, 2023 - 10:41 EDT

Investigating

We have identified an issue with customers starting trials. We are actively working to resolve the issue. We apologize for any inconvenience this may cause.
We encourage you to reach out to support or your account manager so that they can help and circle back with you once the issue is resolved.
Posted Sep 26, 2023 - 10:12 EDT
This incident affected: Call Tracking (CallRail Web Application).