PCI Insights Delay

Incident Report for CallRail

Resolved

This incident has been resolved, and PCI Insights should be processing normally.
Posted Aug 17, 2026 - 14:06 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 17, 2026 - 13:32 EDT

Investigating

We are investigating an issue that may cause some PCI insights to be delayed. We sincerely apologize for any inconvenience these delays may cause.
Posted Aug 17, 2026 - 13:10 EDT
This incident affected: Conversation Intelligence.