Application Dashboard Outage
Incident Report for CallRail
Resolved
This incident has been resolved.
Posted May 07, 2021 - 13:17 EDT
Monitoring
A fix has been implemented and we are monitoring the results
Posted May 07, 2021 - 13:02 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 07, 2021 - 12:59 EDT
Investigating
We are investigating reports of CallRail application dashboard timeouts.
Posted May 07, 2021 - 12:52 EDT
This incident affected: Application Dashboard and Lead Center.