Google Ads disruption + delayed event updates
Incident Report for CallRail
Resolved
Google Ads has resolved their incident. We've re-enabled the integration and data should be flowing as normal.
Posted Nov 26, 2024 - 08:09 EST
Identified
We've identified a disruption in service in the APIs used by our Google Ads integration. We have temporarily disabled conversion reporting to Google Ads as well as data retrieval of keywords and campaign data while we wait for the Google team to resolve the issue. Users may be unable to activate new Google Ads integrations.

This issue is causing delays to some events, especially events triggered post-call. Some actions such as user management and email notifications may take additional time to process. Call routing is not impacted.
Posted Nov 25, 2024 - 15:49 EST
This incident affected: Integrations (Google Ads) and Email Notifications.