Application dashboard availability interuption
Incident Report for CallRail
Resolved
This incident has been resolved.
Posted Jun 25, 2021 - 14:25 EDT
Monitoring
The application dashboard experienced a brief interruption in availability; the service is available again but we are monitoring the situation until it is fully resolved.
Posted Jun 25, 2021 - 13:04 EDT
This incident affected: Application Dashboard and Lead Center.