Cost-Per-Lead reporting inaccuracies
Incident Report for CallRail
Resolved
This incident has been resolved.
Posted Jul 11, 2023 - 11:15 EDT
Monitoring
The issue with Cost-Per-Lead data reporting has been fixed. We are currently monitoring the backfill of any missing Cost-Per-Lead data during this time period and will update once that is complete.
Posted Jul 10, 2023 - 18:38 EDT
Identified
The issue has been identified and we are currently implementing a fix.
Posted Jul 10, 2023 - 14:36 EDT
Investigating
We are currently investigating an issue where new Cost-Per-Lead data is not being accurately reported. We'll update with more information as it becomes available.
Posted Jul 10, 2023 - 11:03 EDT
This incident affected: Call Tracking (CallRail Web Application).