Issue with agent status in Lead Center
Incident Report for CallRail
Resolved
The earlier incident regarding stuck Lead Center calls is now resolved. We appreciate your patience.
Posted Dec 04, 2023 - 16:47 EST
Monitoring
We have implemented a fix for the Lead Center status issue. We are continuing to monitor the situation to ensure the issue is resolved and agents are no longer stuck in “busy” status. We sincerely apologize for any disruption this issue may have caused.
Posted Dec 04, 2023 - 16:09 EST
Investigating
We are receiving scattered reports of Lead Center agents being stuck in “busy” status and being unable to hang up.
Your ability to place and receive calls is of critical importance to us at CallRail. We are actively working on a resolution and apologize for any disruptions you are experiencing related to this issue.
Posted Dec 04, 2023 - 15:11 EST
This incident affected: Lead Center (Lead Center General, Lead Center Web Application, Softphone).