Call Routing Failures
Incident Report for CallRail
Resolved
We encountered a performance issue during upgrades to our call routing infrastructure. About 20% of calls routing between 11:12 and 11:30 Eastern Time were not able to connect. All functionality has now been restored.
Posted Apr 14, 2020 - 13:17 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2020 - 12:00 EDT
Update
We are continuing to investigate this issue.
Posted Apr 14, 2020 - 11:31 EDT
Investigating
We are currently investigating failures in our call routing system
Posted Apr 14, 2020 - 11:30 EDT
This incident affected: Call Routing.