Delayed event updates
Incident Report for CallRail
Resolved
Delays in Google Ads APIs have cleared, and we've re-enabled conversion reporting.
Posted Jun 26, 2024 - 14:40 EDT
Update
Delays in Google Ads APIs continue, so conversion reporting remains disabled. All other post-call events are processing normally. We'll continue to monitor Google Ads API health and restore conversion reporting when it recovers.
Posted Jun 26, 2024 - 13:59 EDT
Monitoring
We've identified a delay in the APIs used by our Google Ads integration. We have temporarily disabled conversion reporting to Google Ads as well as data retrieval of keywords and campaign data. Users may be unable to activate new Google Ads integrations. Overall CallRail event queue health is improving and we will continue to monitor Google's metrics. We'll re-enable all processes and post any delayed conversions as soon as the APIs have recovered.
Posted Jun 26, 2024 - 11:59 EDT
Identified
We've identified the issue and are working on a fix.
Posted Jun 26, 2024 - 10:57 EDT
Update
We are continuing to investigate this issue.
Posted Jun 26, 2024 - 10:16 EDT
Investigating
Due to some processing queue backups, we are experiencing delays to some events, especially events triggered post-call. Some actions such as user management may take additional time to process.
Posted Jun 26, 2024 - 10:15 EDT
This incident affected: Call Tracking (CallRail Web Application).