Slow load times for Callrail Application

Incident Report for CallRail

Resolved

We believe the slowness issues are resolved and will continue to monitor.
Posted Jul 07, 2022 - 16:38 EDT

Monitoring

The slowness issues with the Callrail app have resolved, we are monitoring the situation closely.
Posted Jul 07, 2022 - 16:03 EDT

Update

We are continuing to investigate reports of slow load times of the CallRail application impacting reporting. Call routing is unaffected.
Posted Jul 07, 2022 - 15:25 EDT

Investigating

We are investigating reports of slow load times of the CallRail application
Posted Jul 07, 2022 - 14:50 EDT
This incident affected: Call Tracking (CallRail Web Application).